Back to overview
Resolved
Infrastructure Shifting
Jul 18, 2026 at 9:58am UTC
–
Jul 18, 2026 at 12:58pm UTC
Affected services
Panel
Billing
Resolved
Jul 18, 2026 at 12:58pm UTC
Maintenance ended
Affected services
Created
Jul 18, 2026 at 9:58am UTC
Panel and Billing will be unavailable but servers won't get affected they will be running.
Affected services